Gizmo's Freeware Forum

Gizmo's Freeware Forum (https://www.techsupportalert.com/freeware-forum/)
-   Mobile Apps (https://www.techsupportalert.com/freeware-forum/mobile-apps/)
-   -   Install app to SD card (https://www.techsupportalert.com/freeware-forum/mobile-apps/10419-install-app-to-sd-card.html)

systemcrash 18. Sep 2012 03:56 PM

Install app to SD card
 
@ IO.Hazard I have noticed that... Some apps with no comments or ratings, still have a 5 star
Some brand new ones have a 5 star rating when they've only just been added.

On another note,

I have added a 8GB SD card into my phone, is there a way i can install and run apps straight from the SD card? without having to (root) the phone? I have tried App 2 SD (move app to SD) but on the Samsung S3 the app doesn't see the external storage, and there's nothing in the settings to change it to extSdCard (the name i got from a file manager that found the external SD card)

I also looked at backup to SD card, I had to point it to extSdcard in the settings. That seemed to work. Just wondering if there's a way to install app to the SD card?

IO.Hazard 18. Sep 2012 04:49 PM

There are many apps that will allow you to move them to the SD card without rooting your phone. Unfortunately, there are some stubborn ones that prefer internal memory and cannot be moved unless you root your phone but still won't work correctly if moved to the SD Card no matter if your phone is rooted or not. This is specially true for widgets and almost all Antivirus apps.

However, I didn't hear about the problems you mention before. The App2SD is a very competent app and should work with your S3. May it be a S3 specific issue perhaps? :confused:

I think you should try AntTek Explorer or the Gemini App Manager since I used them as "Plan B" whenever the App2SD didn't seem work.

systemcrash 19. Sep 2012 12:09 PM

What it seems to be is my Samsung s3 has a 16GB memory. Which is 11GB available. In file managers it shows the memory available on the phone as a SD card
mnt\SdCard and the removable one i can put in and take out is mnt\extSdCard

App2SD only finds the internal mnt\SdCard which isn't removable from the device
so it comes up with a error

"This device does not have a real primary external storage, or the primary external storage is emulate. Moving app to SD function may not be supported on this device"

IO.Hazard 19. Sep 2012 08:56 PM

Well, your problem seems to be caused by the actual SD card being mounted as "/extSdCard/mnt" instead of "/SDCard/mnt", preventing it from being recognized by the App2SD app. I read about S3 users complaining about that badly and claiming it to be a specific S3/ICS issue which hasn't a definitive solution (yet).

If you have tried both the AntTek Explorer and the Gemini App Manager with no results, try formatting your SD card using the linux ext3 partition instead of FAT. Some time ago I had a similar problem with a phone running Gingerbread and it worked well. Unfortunately, I don't have a S3 phone to prove that method, but there's nothing to lose by trying it (assuming you've backed up all your important data prior formatting ;)).

systemcrash 21. Sep 2012 04:20 PM

I thought i would give it a try. i went into the phone storage settings and formatted the card but it gave it the same extension name extSdCard. This may be because the inbuilt storage card has taken the name SdCard. I dont have a card reader for my laptop to insert the SD card into so i have to do it through the phone. I can manage files, and format it. but the windows format option doesn't allow me to change the format type. And also formats it to the same name extSdCard

systemcrash 21. Sep 2012 04:33 PM

Well after looking around it does not seem possible to move apps to the sd card on the Samsung S3. Unless of course you [Root] the phone. Which is disappointing. A brand new phone, i was hoping to avoid rooting it...

I think for now il keep my phone as it is... Il just keep music, videos and all my other stuff on the memory card. Some apps allows me to change the destination for save files so il do that.

If i need more space on the phone even after this il have to root the phone.

For anyone else who already has a rooted phone i find this page that tells how to move the apps to SD car. Im not sure how credible the information is not having rooted my phone.

http://www.jayceooi.com/2012/06/25/h...ernal-sd-card/


All times are GMT +1. The time now is 01:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.