Gizmo's Freeware Forum

Gizmo's Freeware Forum (https://www.techsupportalert.com/freeware-forum/)
-   Internet, Web Apps and Networking (https://www.techsupportalert.com/freeware-forum/internet-web-apps-and-networking/)
-   -   Firefox blocks Java Deployment Toolkit (https://www.techsupportalert.com/freeware-forum/internet-web-apps-and-networking/12153-firefox-blocks-java-deployment-toolkit.html)

Joe A.TT 23. Jul 2013 03:47 AM

Firefox blocks Java Deployment Toolkit
 
Has anyone noticed that Firefox v.22 now blocks Java Deployment Toolkit? See: https://addons.mozilla.org/en-US/firefox/blocked/p428

I just tried to upload some files to my Box cloud storage and it cause FF to crash. Tried again - crashed again. I know Box uses JDK because previously when I tried to upload files with JDK disabled and it didn't work.

FF doesn't even give me a choice to enable or disable the JDK plugin - it's just blocked - end of story. How am I suppose to manage my files on Box then? Go back to IE? :eek:

Another FF link suggests users should contact the developer - Oracle in this case. I have done this, but given the constant security issues with Java, I'm not very hopeful it will be fixed. I also contacted Box about the issue. If I receive any feedback I'll report here.

BTW, the blocking of this plugin may affect users in other ways too.

J_L 23. Jul 2013 06:26 AM

I highly doubt your Box issue has anything to do with Java Deployment Toolkit. It's more than likely to be something in your profile, which more of the time has to do with add-ons. You can try Firefox Portable, and go on Box to verify.

To fix, first try deleting all of you history, cache, and other settings (after backup if you want). Then try Firefox Safe Mode with all add-ons disabled, or even everything reset. If problem goes away troubleshoot (selectively enable) from there. If not, you might need to re-install Firefox (you can still keep your profile).

Anupam 23. Jul 2013 08:07 AM

Joe, like J_L, I too think that JDK might not be responsible here for Box related crashes on Firefox.

How did you try to upload files on Box? By logging into your Box account from the browser? Or, are you using any add-on, or some other means?

I do not have any kind of Java installed on my system. But, even then, I was able to upload a file on Box. I did so by logging into my Box account from within the browser.

I have turned on the option of Click To Play from about:config in Firefox. But, even without activating Flash Player, I was able to upload the file on Box.

Also, even if you install Java on your PC, the JRE, or Java Runtime Environment is the one which is required for Java applets to function on sites. JDK is for development purpose, and when I had Java installed, I used to actually disable the JDK plugin on Firefox.

Do you really need Java on your system. I have uninstalled Java on my system since a long time, and I have not faced any problem with any site so far. But yes, some sites, or programs do require installation of Java, and if you are using such a site where it's really required, then you will have to have it installed.

Which version of JRE are you using? Is it the latest?

You can use Firefox update plugin check to see if it's the latest version. You can also use Secunia PSI to check, if you have it installed on your system.

J_L might be correct in guessing that maybe some other add-on is responsible for crashes on Box.

deya 23. Jul 2013 09:06 AM

Joe; I just used FF 22 to upload some files to Box. No problem, no crash, works fine. Also, Java Development Toolkit plug-in is enabled in the browser. Only got 2 extensions installed, WOT and an Adblocker. I have the latest Java installed.

Anupam 23. Jul 2013 09:13 AM

deya, you can try with JDK disabled too... it should work.

deya 23. Jul 2013 09:49 AM

Ok, disabled the Java Development Toolkit plug-in, uploaded a couple more files to Box. No problem, no crash. Worked fine.

Unlike Joe, I have the option to enable the plug-in, so I re-enabled it. This time, after re-enabling it, I get a warning with a link to the page same as Joe's link, this one;

https://addons.mozilla.org/en-US/firefox/blocked/p428

It wasn't there before. But the plug-in is now enabled and the option button to disable it is still there. Still works, but with the warning.

Anupam 23. Jul 2013 09:54 AM

Quote:

Originally Posted by deya (Post 90103)
Ok, disabled the Java Development Toolkit plug-in, uploaded a couple more files to Box. No problem, no crash. Worked fine.

As I thought. You should keep it disabled. It has no use for general users. JRE is the one you need to keep Java working.

deya 23. Jul 2013 09:58 AM

Yep, disabled. Must be something else with Joe's set up.

Joe A.TT 23. Jul 2013 02:54 PM

Thanks for testing and the feedback guys - I appreciate it :).

Anupam, like you, I also access Box from my FF browser. I don't use a desktop app or plugins for this.

I've tested further with FF unsandboxed and with JDK disabled, and was able to upload files to Box.

Testing the same with FF sandboxed (i.e. running in Sandboxie 4.03) and with JDK disabled, FF crashes again.

Conclusion: Sandboxie is the culprit.

And yes Anupam, I keep JDK disabled. However, in the past, I found I had to enable it in order to upload files to Box once FF was running sandboxed. Uploading used to work in a sandboxed FF only if JDK was enabled. Now, regardless of whether JDK is enabled or not, FF would crash once I try to upload to Box. And yes, JDK is up-to-date - version 7.0.50.255 10.5.1.255.

I'm going to report the crash on Sandboxie's forums and see what Tzuk has to say. I'll post any feedback to this thread.

As for Java, I uninstalled it more than 6 months ago. I don't miss it and I haven't encountered any sites or programs that need it. Question here: Even though Java has been uninstalled, I still have Sun and Oracle folders in C:\Users\<username>\AppData\LocalLow. Are these leftovers I can safely delete?

Anupam 23. Jul 2013 03:05 PM

Joe, good to know you located the fault :). Strange one though, that in Sandboxie, Box used to open with JDK installed. Weird.

You said you have removed Java.. but you still wrote about having JDK plugin? How is that? :confused: ... it should have been removed with Java.

You can try JavaRa to remove Java and all its traces from the system.

http://singularlabs.com/software/javara/


All times are GMT +1. The time now is 11:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.