Gizmos Freeware Reviews  

Go Back   Gizmo's Freeware Forum > Freeware Forum > General Computer Support

Reply
 
Thread Tools Display Modes
Old 16. May 2011, 04:02 AM   #1 (permalink)
Senior Member
 
Join Date: Mar 2011
Posts: 153
Default Windows System Icons

Hi guys.

This query goes to anyone that is familiar with icon modding in Windows.

I have recently plunged into modifying the appearance of my Windows 7 x64 SP1 system.

The issue I am having is that I applied a new icon pack to replace the boring Windows ones. The icons that get changed are the ones such as My Computer, Drive icons in explorer, all folder icons in explorer basically, and icons inside control panel category view.

The icon pack I applied did not work properly (I do not know why as it was a very well reputed one by a user that has made many many icon packs and many others have raved about and had success with it). Only some of the icons changed and the ones that did appear would alter depending on the view type (medium icons, list view, details view etc.). This makes me think that it has something to do with my screen resolution, I have a large screen. But this I do not know, as I don't even know if the screen res can have an affect on an icon pack.

Anyhow, I tried to change back to the native Windows icons by replacing the files that I had to change with the originals that I backed up. This went successfully and most of the modded icons are now gone, but in a rare occasion some of the altered ones still appear, would anyone know why this would be the case, or just a way of getting the original Windows ones back as its very irritating having a mix and match of icons.

And to give as much info as possible, the files that I had to change were the following:

C:\Windows\system32\

imageres.dll
imagesp1.dll
shell32.dll
zipfldr.dll

and

C:\Windows\sysWOW64\

imageres.dll
imagesp1.dll
shell32.dll
zipfldr.dll
rikishi19 is offline   Reply With Quote
Old 16. May 2011, 09:47 AM   #2 (permalink)
Senior Member
 
Join Date: Mar 2011
Posts: 153
Default Solved

OK, I have found the answer to my problem. So seeing as I found the answer before there was a reply, please feel free to close this thread.

I will provide the answer incase this is left open and someone else comes across a similar issue.

Solution:

The problem, with both the icon pack not working properly when applied and some of those icons not going away after reinstating the original Windows icon files was that the systems icon cache has to be cleared after the change has been made (in both cases). I used Ccleaner to do this and all modded icons now appear and Windows ones appear when reverting back to those.
rikishi19 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT +1. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.