Gizmo's Freeware Forum

Gizmo's Freeware Forum (
-   General Computer Support (
-   -   Salvage data from a dying hard drive (

Anupam 04. Sep 2013 09:28 AM

Salvage data from a dying hard drive
My friend had a 1 TB WD Green hard drive in his system. It went bad recently. The hard drive makes lot of clicking noises, and it takes a lot of time for system to boot, or, work, with the drive in the system.

I know that once a hard drive starts to make clicking noises, and behaves like mentioned above, there are not much chances of retrieval of data from it.

But, I still want to try before we give the hard drive for replacement. The amount of data in the hard drive is large, and it would be good if some of it could be salvaged. My friend is a photographer and does video too, for weddings, etc. So, the hard drive holds recordings of those. Now, fortunately, he has done the work for his customers, and provided them with their videos and photos... but still, apart from those recordings, there were his personal files too.

Now, when the drive was in his system, which has Win XP SP3 installed on it, he says that one day, he got an error message while accessing one of the partitions on the drive. He is not very well versed with computers, or English, so he does not remember the exact message, but he claims that it said "Don't format" in the message. He said he pressed OK for the message.

Now, after that, when he rebooted, the hard drive was no longer visible on his system. Yes, it shows up in BIOS, but not in Windows, nor in Disk Management.

I guess he somehow did not read the error message properly, and I think when he pressed OK, the disk had started to format, or something like that.

On his system, the disk does not show up at all in Windows. No hope there.

So, I bought the disk to my house, and I put it in my computer, which has Windows 8. On my system, the disk does show up in Disk Management, but, Windows says it's an uninitialized hard disk. It's like it was a new hard drive, with no data or partitions on it. The hard drive had 4 partitions on it, but none are visible. I pressed OK to initialize the disk, but it was not done, because of IO errors.

I tried to run Minitool Partition Wizard on it, which has feature of partition recovery. But, it too does not see any partitions, and therefore, no option to recover.

I guess the partition table might have gone. A 1 TB hard disk cannot lose such huge amount of data in short time. So, I think if somehow there is a way to recover partition information, and show the partitions, then maybe some of the data can be copied... although that would be difficult too, given the condition of the disk.

But, I still want to try, because we would be giving the hard disk for replacement anyways... so, it will be an experiment, and if things are successful even a bit, I will get to learn something, and probably save some data as bonus.

So, is there any way in which the partition information, or data on this hard disk can be shown somehow?

torres-no-tan-magnifico 04. Sep 2013 12:15 PM

Hi anupam,

Perhaps you could give TestDisk a spin:

The freeware for data recovery tend to have a 1 GB limit - not sure about the limit for TestDisk.

More info here:

HTH :)

sicknero 04. Sep 2013 01:00 PM

Yikes... I have a 2tb WD My Passport, which has failed completely. It seems that this range from WD is prone to problems, if you go onto Tom's Hardware site there are several threads about them as well as elsewhere on the net.

I've given up on mine, Windows knows that it's connected but that's all, the LED just blinks away endlessly. I can't open it or even reformat it. I can't even open Drive Management unless I disconnect it.

I've tried pretty much everything I can think of it, different cables, different PCs, even different OSs and all the partition recovery programs I can get my hands on. Most don't even see it, some see it but can't do anything with it. I do have one small app which can see it and can apparently rewrite partition info but it didn't help with my drive unfortunately. I forget the name of it but it's on my laptop so I can post details later if you like.

With mine there were warning signals ... for a while it was refusing to "disconnect safely" although checkdisk couldn't find anything wrong with it. Also the (utterly pointless to me) WD SES driver kept re-installing itself. With hindsight I should have backed everything up as soon as those symptoms started.

Anupam 04. Sep 2013 02:36 PM

Thanks Torres.. I was thinking of giving a try to TestDisk too. I will give it a try.

I will wait for a few time for more suggestions, so that I can try them all when I plug in the drive again.. I don't want to plug it again and again, because it's condition is not good, and it also causes a lot of delay for PC to boot.

sicknero, you are talking about a different drive.. although ours are both WD. Mine is an internal hard drive, whereas yours is external I think, guessing by the model.

When we bought WD Green, at that time, Seagate drives were failing all over, and so we decided to go with WD Green. WD Blue was not available, which is better than Green.. and WD Black was too costly. So, we decided to go for WD Green. But, it turns out, WD Green are not as reliable.

From what you say, yes, your hard drive seems like nothing can be done about it.

Yes, I would like to know which software is that. It's always good to know about such software. You never know when you might need them :).

A portable drive can refuse to disconnect even when a process is using it. Sometimes, it's the explorer. Or, even if you close a program which accessed the drive, sometimes that program can take time to fully close itself from the memory. That time too, the drive will refuse to disconnect.
For such issues, I have found Emco Unlock-IT to be quite good. I had a pen drive, and whenever I used it on my XP system, for some reason, the explorer.exe kept accessing it, and kept it locked. Unlocker was unsuccessful in detecting that. I tried Emco Unlock-IT and it successfully detected the lock by explorer.exe and was able to remove that lock. Very useful.

Yes, it's always good to backup data on first signs of trouble. Sometimes, it can be too late. And these things have a tendency to go down, right when you need them, or you haven't taken a backup :D. Good to be careful.

sicknero 04. Sep 2013 03:53 PM

Ah OK, thanks. I didn't realise that Green is an internal drive, although there seem to be quite a few posters having problems with that too on Tom's &c. My Passport is an external pocket-sized drive yes, and aside from the clicking the symptoms sound very similar.

This is the program I tried - Dti Data - and to be fair I wasn't exactly sure what I was doing with it. I was past worrying about data loss though by that point, and there wasn't anything much irreplaceable on the drive anyway.

Thanks for the Emco suggestion, it honestly hadn't occurred to me to try a file/folder unlocker. I was using HotSwap though never quite sure if might not have been doing more harm than good.

Anupam 04. Sep 2013 04:03 PM

Thanks for that program. I downloaded it. Might be useful. I will try it on the hard drive, to see if it shows partitions or not. I won't try its Write function though.

HotSwap is not meant to be used for USB/External drives. It's meant to be used for SATA/eSATA drives, which have been made for external use. Atleast that's what I make of it. If you have been using it on your external drive, I don't know what effect it might have had. Please don't use it on a simple external drive.

For external drives, the simple Windows function provided to safely remove is sufficient. In case a process is locking it, that time the drive will refuse to be removed. Sometimes, we forget that a folder from the drive is open. In that case, the drive won't disconnect. At other times, like I posted before, some process might be locking it, and an unlocker software is useful in such cases.

An external drive/pen drive should not be removed without removing it safely, as it can cause data loss, and also make the drive bad.

sicknero 04. Sep 2013 04:20 PM

I didn't realise that Hotswap shouldn't be used with externals, it has an entry in the Device Type menu for Removable Disk Drives which I thought covered USB. I used it for a while after the Safely Remove option in Windows stopped working (even after I'd closed all the windows and processes that I could) and it did work for a brief while. Possibly then I did do some irreparable damage to the partition.

Thanks for the advice about Hotswap though, I'll definitely remember that and use a file/folder unlocker if I come across this problem again. I have quite a stack of external drives so it's not improbable.

Some of my friends take the mickey about my always insisting on Safely Remove ... typical that it's my USB drive that breaks :-D

Anupam 04. Sep 2013 04:40 PM

HotSwap is meant for SATA and eSATA drives that have been converted to an external drive using a SATA Host Controller or an adapter, as shown in the figures below. It also lists which devices are supported.

Well, maybe you experiment on the drives too much :p

kendall.a 04. Sep 2013 05:39 PM

Anupam, I sent you a PM with a suggestion.

joeguru 07. Sep 2013 03:06 AM

The clicking noise is indicative of mechanical hard drive failure. Usually software won't help this issue. It's possible to recover the data by a professional data recovery service, but they usually charge several hundred US dollars. The more you run the drive, the more data that may become damaged.

All times are GMT +1. The time now is 05:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.