View Single Post
Old 25. Dec 2010, 06:55 AM   #10 (permalink)
Jojo Yee
Maestro di Search
 
Jojo Yee's Avatar
 
Join Date: Jul 2008
Posts: 7,825
Default

Quote:
Originally Posted by wdhpr View Post
Does your all-in-one Lexmark work with Linux? If so did your Linux OS find the right drive on its own or did you have to find a workable driver? Mine was a X1185 and I couldn't make it work with Linux. It had to be a driver issue with my model
Mine is Lexmark 3350 which was given as a free gift. For the purpose of testing it, I connected it to Linux Mint, it detected the printer as Lexmark 3300 series but I couldn't get it to print. I pasted http://localhost:631/printers/ to the browser, it showed up the printer Lexmark 3300 and the print jobs were completed as far as the CUPS was concerned. But the printer didn't print out a single page.

Obviously Lexmark has not provided a driver for this model. It has a driver for Windows and Mac OS. I connected it to Windows, it detected and installed the driver. A test print on the printer worked well.

So if you need a printer to work with Linux, need to check if there's a driver support for the system. At work, I've a printer of the other brand and it worked with Linux. Here's a related topic a few years back: "Printer manufacturers are starting to provide Linux drivers for users to feed to CUPS." according to The Print Shop: Linux Drivers Made Easy

Last edited by Jojoyee; 25. Dec 2010 at 07:02 AM.
Jojo Yee is offline   Reply With Quote