View Single Post
Old 14. Sep 2010, 11:16 PM   #1 (permalink)
mikecorbeil
Banned
 
Join Date: Sep 2009
Posts: 57
Default Unable to uninstall Emsisoft and Auslogics... Help?

I installed the latest versions of Emsisoft Anti-Malware (EAM) and Auslogics Disk Defrag (ADD) on Sunday and wanted to reinstall EAM only as freeware, and to uninstall ADD for a while to free up a little disk space, now that I'm presently forced to have to work with only my old 20GB hard drive, have three other defraggers installed, and they're enough.

unins000.msg, .dat and .exe:

The two applications are supposed to install unins000.exe along with the similarly named .msg and .dat files, but the latter two somehow got disappeared, maybe extraordinarily renditioned, and this left only the .exe's. The uninstallers refuse to work without the .msg file, but during my searches, one discussion page at Emsisoft was begun by a user who installed EAM and wanted to uninstall it, but had the same problem; the missing .msg file. Another user posted that he was first refused the uninstall because of the missing .dat file. So, apparently both of those files are needed to be able to run the .exe.

The first of those users later posted that he finally managed to be able to do the uninstall by doing a separate second install to a different directory or path, copied the needed unins000 files to the directory of the original install, and then ran the uninstaller. He didn't say that he uninstalled the second install before uninstalling the first one, but I've been guessing that he did.

I could not make a second install of EAM, but was able to make a second one for ADD, copied the .msg and .dat files to the original install directory, uninstalled the second install, and then double-clicked on the .exe for the first installation, because ADD was no longer listed in Add/Remove Programs.

The first installation still can't be uninstalled. While the .msg and .dat files are there with the .exe, I still get the error message saying that the .msg file is missing and that I need to either do another installation or to get a different copy of the application to install. I checked the Windows registry to see if it specifies anything about the .msg and .dat files, but there is nothing about these files in the registry.

That's nonsense. And I can't do another and separate installation of EAM, though could for ADD. Trying to do another install causes a fatal error, so the installation is refused.

Not a problem with other applications

I have other applications that installed with the unins000.exe, .msg and .dat files, though there are also some that installed without a .dat file. There are no problems with these applications. Uninstalling and reinstalling them generates no errors.

Registry restore to Saturday failed

Since EAM and ADD were installed on Sunday and I had, this morning anyway, a couple of system restore points Windows made on Saturday, I tried to restore to one of that day. This was to remove all changes made to the registry for these two applications.

This also failed. While the desktop was fine all of Saturday, Sunday, Monday and this morning, the restore (to Saturday) this morning failed. The desktop would not load correctly and this apparently was due to some script related or connected to the desktop; and I don't know what script this is.

What's the cause of the uninstall error and is editing the registry a solution?

I could manually, with a registry editor, remove everything related to ADD and EAM in the Windows registry. It'd be more tedious than simply doing a system restore to Saturday, if that worked, but removing the changes in the registry using an editor is do-able.

Would that put an end to the uninstall errors? If not, then could I then simply delete the ADD and EAM installation directories; or would this still be refused by the system or OS? I can't delete them now; it's refused.

I tried deleting one of the two directories this morning, but this was refused by the system and I think to recall that it had something to do with permissions. So I brought up the Properties for the parent folders of the installations for ADD and EAM to see if there was a way to modify the permissions on these directories, but that's not provided in the Properties tab (or whatever it's called).

While I had the Windows registry opened in a registry editor, I happened to right-click on one of the principal keys for EAM and saw that one option was Properties, so I selected it and then saw that we can change the permissions for the user who's logged in. So I set my permissions to full in order to see if this would permit deleting the EAM directory, and rebooted, first, after making these permission changes, so that the registry would be reloaded. But the directory remains undeletable.

Windows and the installers of some applications apparently don't have a problem with silently deleting installation directories of some of the other applications, but when I try to do it with EAM and ADD, then I get a fatal error.

That's a rotten deal.

Are there any magical uninstaller applications?

Zsoft Uninstaller and Revo both use the application uninstallers, so the .msg file is missing when using these two tools.

AppRemover (AR) seemed to possibly be an answer based on what I read about it in the best uninstallers review page here, but I tried two times during the night of Sunday to Monday to use AR and it takes [forever]. The first 40% or a little less of the scan for AV or anti-malware applications goes quickly enough; very acceptable. But to get to roughly 60% takes a couple of hours and the scan seems to get slower as the amount scanned increases.

For the first run with AR, I hadn't closed or terminated Avira Antivir 9 and Threatfire, and believe to have left Avira's Guard active and Threatfire non-suspended. So before trying to run AR a second time, I disabled Avira and Threatfire as startups, deactivated their active protection, and then rebooted. But it didn't make any difference. AR was still painfully slow with its scan of the system.

Closing:

So any information that can or might help for uninstalling ADD and EAM would be greatly appreciated.

I manually editing the Windows registry to remove all changes related to ADD and EAM is a suggestion and I'm still left unable to delete the installation directories for them, then what?

Is there a Windows system file that has locks that cause this sort of problem, by any chance?

Last edited by mikecorbeil; 14. Sep 2010 at 11:16 PM. Reason: Forgot to select instant notification
mikecorbeil is offline   Reply With Quote