LastPass Not Working in Firefox? It's Not Just You

toggle-button

LastPassFinds of the WeekThe latest LastPass Firefox update (version 4.9.0) is causing the LastPass Firefox add-on to stop working in several versions of Windows (from Windows 7 to Windows 10) and several versions of Firefox. Here's a work around to keep it running.

If you use Lastpass on Firefox, Waterfox. Cyberfox, Pale Moon or another Firefox fork and it doesn't respond when you click on the LastPass toolbar icon, it's not just you. Not only is there no response when clicking on the icon in the toolbar but none of the usual pop up options appear below the icon. There are several reports from users indicating this is a Firefox issue, as Chrome, Vivaldi and Opera are not experiencing problems with the add-on so far.

As yet there's been no word from LastPass about this, but luckily there's a work-around.

First you'll need to remove the current LastPass version in the Firefox add-on section. Use the three vertical line "hamburger" menu at the top right and choose Add-ons, find the Last Pass entry, and click Remove.

Next, download version 4.7.1 from the LastPass Password Manager Version History page at the Firefox Add-on site by clicking the +Add to Firefox button next to version 4.7.1.

Once it's installed, you'll need to disable the add-on from updating, or it will update and stop working again.

To disable the update, go to Add-ons using the three horizontal line menu at the top right and clicking on Add-ons, then make sure you're in the Extensions section using the menu at the left. Find the LastPass: Free Password Manager entry, and click on "More". It's right under the Last Pass Free Password Manager title.

Then, scroll down to the bottom, and when you see Automatic Update, click the Off button.
That will stop the add-on from updating and will let you use Last Pass without any issues until the issue is fixed.

That should keep your LastPass add-on working until the issue is fixed. I'll keep an eye out and when I know something, I'll pass it along. When it's resolved, you'll have to uncheck the button and allow the add-on to update. It should do so automatically, but if not, you can install the latest version by visiting the LastPass add-on page.

Update: 4 April 2018
No response from LastPass as yet. Their forum is viewable here: LastPass Forums • View topic - Firefox Extension won't open

Note that version 4.7.1 of LastPass was available for download this afternoon at places like File Hippo, where there are earlier versions, but when I looked this evening, only the newest version was available. Earlier versions can only be found at the Mozilla Firefox site as far as I can tell. All major download sites are now showing version 4.9.0.

That's it. :)


You can find more Tech Treats here.

 

Please rate this article: 

Your rating: None
4.80769
Average: 4.8 (78 votes)
toggle-button

Comments

You're more than welcome. I'm glad you got it worked out. :)

Fortunately, my Lastpass is working fine: it was updated to 4.9.0 on 31st March. I'm running FF 59.0.2 (32-bit) on Linux MX-16.

Many thanks for the info, Rhiannon.

Torres

 

So far, only Windows is being mentioned in the reports.

I note that you say the update to v 4.9.0 was released on 1st April but my LastPass add-on updated to this version on Friday 30th March with that release date shown and I have had no problems with it since (I am using Firefox 59.0.2 on Windows 10 Pro Version 1709 (OS Build 16299.334)).

Perhaps this problem update was a re-release which did not affect those whose whose version had already auto-updated.

(Edit: I also have the binary component installed and use LastPass in Firefox, Chrome, IE 11 and Edge)

You're correct. :)
The add-on was updated 29 March. The issue didn't appear on my system until yesterday, 1 April.  I've amended the article.
 

Hi Rhiannon

I have an update on LastPass issues which may be relevant to this thread. A week or so ago LP stopped remembering my sign-in email and preferences but this turned out to be a corrupted Firefox profile and not in fact a LP problem. There were threads on the LP forum on this particular issue but none were recent and when I checked on my spare laptop - which is rarely used but updated and set up to be as near identical to the main one as possible - LP was working normally.

I had also occasionally had problems with being signed out of the Ghostery extension and with Firefox restoring an older session instead of the last one when restarted which led me to the corrupt profile conclusion so I removed all traces of Firefox using Revo's advanced setting then re-installed it. I signed into my FF account - which incidentally now offers 2-factor authentication - to set everything up again and now after a week all is still working normally. LastPass is now version 4.13.1.10 on my device.

I realise some users may blanch at the idea of deleting their profile and setting up again from scratch but if you sync with a Firefox account, export settings files in advance from add-ons which allow that, like Ghostery and Imagus in my case, ready to import to the new installation it doesn't really take that long and in my view the refresh is worth it.

Hope this helps.

Thanks for those suggestions. That might be a good fix for some people, a corrupt profile can cause problems.
In that time frame uninstalled and did a clean reinstall of Firefox (not restoring the profile - I wiped everything then added bookmarks, add-ons and search plug-ins one at a time) and still had the problem.

I was having the same issue with two out of three up-to-date Chrome based browsers so I was tending towards it being a Last Pass issue. The issue got sorted with updated releases of Last Pass in the Chrome based browsers but not with Firefox.
 

Pages