End-User Support:Operating Systems

Windows CE

Support Tips

Windows CE is at the heart of a growing number of handheld and palmtop computers.
Although it is very similar in operation to Windows 3 and 95, it does have unique
features which support staff must bear in mind.

indows CE, now at version
2.0, is Microsoft’s compct
version of Windows for

palmtop and handheld computers. Mi-
crosoft is also working with various
hardware manufacturers to integrate
CE into other devices, including cars
(the Auto PC, announced recently) and
games consoles (such as the one that
Sega is currently working on).

Much of Windows CE works like
any other version of Windows. How-
ever, the unique features of CE, and of
the hardware on which it runs, mean
that there are additional problems that
support staff who look after users of
CE may encounter.

The majority of problems involve
synchronization between handheld
PCs and desktop computers, though
there are also other potential troubles.

My users of Pocket Outlook are com-
plaining that, when they try to editan
existing appointment, the program
creates a completely new appoint-
ment.

This can occur if the user double-taps
the appointment when wanting to edit
it. Doing so will indeed create a new
one rather than allowing the existing
one to be edited.

Microsoft has agreed that this is a
bug, but no fix has yet been released.
Meanwhile, to edit an appointment,
inform the user to single-tap the ap-
pointment and then select Edit Item
from the Edit menu.

Users are having problems when
opening an appointment in Calendar
or Contacts.

A common cause of such problems is
when the appointment is too large
(more than 20 KB). Split the appoint-
ment into more than one. This will
help solve problems such as:

e The user does not see drawings cre-
ated with the Ink tool in the Tap
Here To Add Notes box.

¢ The contents of the note are not se-
lected when you tap Select All on
the Edit menu in the Tap Here To
Add Notes window.

e The handheld PC (H/PC) hangs
when you change the value in the
Zoom box in the Tap Here To Add
Notes window.

e The note is not saved when you tap
OK in the Tap Here To Add Notes
window.

e ActiveSync may hang when the
H/PC is synchronized with the
desktop computer.

¢ Ink Notes may be displayed incor-
rectly in Microsoft Outlook 97.

A user has complained that he can’t
transfer a file larger than 4 MB from
a desktop computer to an H/PC.

This 4 MB limit is a limitation of Win-
dows CE 2.0 and will be fixed at a later
date.

Meanwhile, the solution is to split
the file into multiple parts or to com-
press it in order to reduce its size. Al-
ternatively, use a third-party file
transfer tool.

When a user double-taps the Inbox
icon to start Pocket Outlook, we
sometimes get a Fatal Application er-
ror message or the program hangs.

By PCSA Staff

This can occur if you add more than 18
information services to Pocket Out-
look, and is a known bug.

How do we add or delete an all-day
event using Calendar in Windows
CE?

To add an all-day event, do the follow-
ing:

1 Double-tap Calendar.

2 Onthe File menu, tap New All Day
Event.

3 Type the information about this
event, and then tap OK.

4 Quit Calendar.

To delete an all-day event:

Double-tap Calendar.

On the View menu, tap Agenda.

In the Appointments And Events

box, tap the all-day event you want

to delete.

4 On the Edit menu, tap Delete Item,
and then tap OK.

5 Quit Calendar.

WN -

A user has mentioned that, when
copying or moving an email message
using Pocket Outlook, an incomplete
email message, meeting request or
file attachment is sometimes created.

This can happen if you copy or move
an email message when you are con-
nected to your email server and the
“Include <n> lines of the message
body” check box is selected in Pocket
Outlook. To prevent the problem:

1 Double-tap Inbox.
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2 On the Service menu, tap Proper-
ties, tap Next, and then tap Next.

3 Tap Full Copy Of All Messages
(slowvest).

4 Tap the Meeting Requests and File
Attachments check boxes to select
them, and then tap Finish.

5 Quit Pocket Outlook.

When we paste a note into an ap-
pointment, contact or task in Win-
dows CE, the pasted text sometimes
contains additional blank lines.

This can occur if you paste more than
1 KB of data into a Tap Here To Add
Notes box in Windows CE. It’'s a
known bug in CE 2.0.

When using Windows Explorer on an

ated copy file is deleted with no
warning.

Although this has been reported by
users as a bug, Microsoft claims that
this is the intended behaviour. Ex-
plorer does not prompt you to confirm
that you want to delete the copy file
when you use the Undo Copy com-
mand. The original file is available to
be copied again.

When a user synchronizes an H/PC
with the desktop computer, the wrong
email information service starts.

This can occur if the email information
service the user requires is not the de-
fault in Microsoft Exchange. To fix it,
do either of the following:

email program you want to use be-
fore you synchronize the desktop
computer with your H/PC.

e Configure the default profile in Ex-
change to include the information
service you want to use.

When synchronizing an H/PC with a
desktop computer, we get a message
something like: “The following ap-
pointment is in conflict. Please run
Microsoft Outlook to resolve the con-
flict before you synchronize again”.
What does this mean?

This can occur if the user has not syn-
chronized the Offline folder in Outlook
97 or Microsoft Exchange. To fix it, syn-
chronize the Offline folder. To do so:

H/PC, if the user taps Undo Copy on
the Edit menu the most recently cre- o

On the desktop computer, open the

1 On the desktop computer, start
Outlook 97 or Exchange.

Can | speed up the synchronization process between an
H/PC and a desktop?

Possibly. Try increasing the speed of the desktop’s serial
port as follows:

1 Click Start, point to Settings, and then click Control
Panel.

2 Double-click System.

3 Click the Device Manager tab.

4 Double-click the Ports (COM & LPT) branch to expand
it.

5 Double-click the communications port to which the
H/PC is connected.

6 Click the Port Settings tab.

7 Inthe Bits Per Second box, click a faster speed, and then
click OK.

8 Click OK.

9 Restart the computer.

10. On the H/PC, tap Start, tap Settings, and then tap
Control Panel.

11. Double-tap Communications.

12. Tap the PC Connection tab, and then tap Change.

13. In the Connect To Desktop Computer Using box, tap the
same speed you clicked on the desktop computer, and
then tap OK.

14. Tap OK, and then close Control Panel.

It may also be helpful to change the ActiveSync options in
Mobile Devices. To do this:

1 On the desktop computer, click Start, point to Pro-
grams, point to Microsoft Windows CE Services, and
then click Mobile Devices.

2 Click the mobile device, and then click ActiveSync

Options on the Tools menu.

3 In the Synchronization Services box, double-click Ap-
pointments in the Type column.

4 Click “Synchronize only the <x> past weeks of ap-

pointments and <y> future weeks of appointments”,

where <x>and <y> are the numbers of past and future
weeks of appointments you want to synchronize, and
then click smaller values for both numbers.

Click OK.

Double-click Contacts in the Type column.

Click the “Synchronize only contacts in selected cate-

gories below” option, and then click OK.

8 Double-click Task in the Type column.

9 Click either “Synchronize Only Incomplete Tasks”,
“Synchronize only the <x> past weeks of active tasks|
and <y> future weeks of active tasks”, or “Synchronize
only tasks in the selected categories below”.

10 Click OK.

11 Double-click Message in the Type column.

12 Click the “To save space copy at most <n> lines”
check box to select it, and then type a smaller value
for <n>.

13 Click the “Limit email received in last <n> days”
check box to select it, and then type a smaller value
for <n>.

14 Click the Include File Attachments check box to clear
it, and then click OK. (Note that clearing this check
box prevents files attached to email messages from
updating during the synchronization process.)

15 Double-click File in the Type column.

16 In the Files Synchronized box, click a file type you do
not need to synchronize, and then click Remove.
Repeat this step for each file type you do not need
to synchronize.

17 Click OK.
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2 On the Tools menu, click Synchro-
nize, and then click All Folders.

When a user connects an H/PC to a
desktop machine running Windows
CE Services, he gets an error message
of “Unable to connect to your mobile
device. It is not compatible with the
version of Windows CE Services cur-
rently installed on this desktop com-
puter”.

This happens if the WaitV2Timeout-
Seconds setting in the Registry is not
configured correctly on the desktop PC.
To fix it, increase the Value Data entry
for the WaitV2TimeoutSeconds dword
value in the HKEY_LOCAL_MACH-
INE\Software\Microsoft\Windows
CE Services registry key.

The maximum entry is 10 and the
defaultis 4. If you increase the entry to
greater than 10, the H/PC may fail to
synchronize properly.

When we install Windows CE Serv-
ices on a desktop computer running
Windows NT 4.0, the desktop is
blank when we restart the machine.

This can occur if you install Windows
CE Services after you install Windows
NT 4.0 Service Pack 3 and Internet Ex-
plorer 4.0. To fix the problem:

1 Press CTRL+ALT+DELETE, and
then click Task Manager.

2 Click New Task, click Browse, and
then open the \Winnt\System32
folder on the system drive.

3 Right-click the Appwiz.cpl file, and
then click Open With Control Panel.

4 Inthe Browse dialog box, click Can-
cel.

5 Inthe Create New Task dialog box,

click Cancel.

Quit Windows NT Task Manager.

On the Install/Uninstall tab of the

Add/Remove Programs tool, click

Microsoft Internet Explorer 4.0 in

the list of installed programs, and

then click Add/Remove.

8 Restart the computer.

9 Reinstall Windows CE Services,
Windows NT 4.0 Service Pack 3 and
|E4, in that order.
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When a user attaches a file in a Pocket
Outlook email message, we some-

Windows CE Tips

times get “Error sending message.
Could not format an attachment for
sending”.

This can occur if there is not enough
memory available to convert the at-
tachment to the Handheld PC format.
To fix it, on the H/PC, quit all pro-
grams that are running except Pocket
Outlook. Test to see if the problem still
exists. If it does:

1 Tap Start, tap Settings, and then tap
Control Panel.

2 Double-tap System, and then tap
the Memory tab.

3 Move the Storage Memory/Pro-
gram Memory slider to the left, and
then tap OK.

4 Close Control Panel.

A user has restored a backup onto an
H/PC but is now having problems
opening email messages in the Inbox.

This problem can occur if the email
messages on the H/PC are not linked
to messages on the user’s email server.
To fix it, synchronize the H/PC with
the desktop computer as follows:

1 Connect the H/PC to your desktop
computer.

2 Tap Start, tap Programs, tap Com-
munication, and then tap Ac-
tiveSync.

3 Tap Sync Now, and then tap Dis-
connect.

When synchronizing, we're getting
“There was a problem synchronizing
<file name> to your mobile device.
Please make sure the file is not in use
on your mobile device”.

The file the user is trying to synchro-
nize probably has the Compressed at-
tribute enabled. This attribute is
available only for files on an NTFS par-
tition. Disable the Compressed attrib-
ute of the file as follows:

1 Onthedesktop computer, move the
file that is generating the error mes-
sage from the Synchronized Files
folder to the Windows NT desktop.

2 Synchronize the H/PC with the
desktop computer.

3 Right-click the file, and then click

Properties.

4 Click the Compressed check box to
clear it, and then click OK.

5 Move the file to the Synchronized
Files folder.

6 Synchronize the H/PC with the
desktop computer.

Sometimes, when we copy a file from
a desktop computer to an H/PC, the
file on the H/PC appears to be empty.

A possible cause of this problem is that
the file conversion properties are con-
figured incorrectly in Mobile Devices.
To fix it:

1 On the desktop computer, click
Start, point to Programs, point to
Microsoft Windows CE Services,
and then click Mobile Devices.

2 On the Tools menu, click File Con-
version.

3 On the Desktop - Device tab, click
the file type you want in the Mobile
Device Convertible File Types box
and then click Edit.

4 In the Type box, click the file type
that you want, click OK, and then
click OK.

5 Close the Mobile Devices window.

When a user synchronizes the hand-
held PC with the desktop computer,
information in Outlook 97 such as
contacts, appointments and tasks are
missing.

Your user has probably neglected to
import the data from Microsoft Sched-
ule+ into Outlook 97. To do this:

1 Start Outlook 97.

2 Onthe File menu, click Import And
Export.

3 Click Import from Schedule+ Or An-
other Program File and then click Next.

4 Click Schedule+ 7.0, and then click
Next.

5 Verify that the File To Import path is
correct, click an option to determine
how Outlook 97 should handle du-
plicate items, and then click Next.

6 Click the items to import, and then
click Finish.

Can | change the default file format
used when converting a file between
an H/PC and a desktop PC?
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Yes. Do it like this:

1 Connect the H/PC to the desktop
computer.

2 On the desktop computer, click
Start, point to Programs, point to
Microsoft Windows CE Services,
and then click Mobile Devices.

3 On the Tools menu, click File Con-
version.

4 On the Device - Desktop tab, click
the file type you want in the Mobile
Device Convertible File Types box,
and then click Edit.

5 In the Type box, click the file type
you want to convert, and then click
OK.

6 Repeat steps 4-5 for each file type
you want to convert, and then con-
tinue to the next step.

7 On the Desktop - Device tab, click
the file type you want in the Desk-
top Computer Convertible File
Types box, and then click Edit.

8 In the Type box, click the file type
you want to convert, and then click
OK.

9 Repeat steps 7-8 for each file type
you want to convert, and then con-
tinue to the next step.

10 Click OK, and then close the Mobile
Devices window.

When synchronizing a handheld PC
with a desktop computer, appoint-
ments in Outlook 97 appear to be
scheduled an hour earlier or later
than the same appointments in
Pocket Outlook.

This behaviour can occur if Outlook 97
isconfigured to adjust for daylight sav-
ing time. To avoid the problem, Mi-
crosoft recommends the following:

1 On the desktop computer, click
Start, point to Programs, and then
click Microsoft Outlook.

On the Tools menu, click Options.
Onthe Calendar tab, click Time Zone.
Click the Adjust For Daylight Sav-
ing Time check box to clear it, and
then click OK.

5 Click OK.
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Why are we getting error messages
such as “Unable to load graphics con-
version filter. Cannot convert file..”
or “Slide Export: Sorry, PowerPoint

could not export the slides(s) because
no installed converter supports this
file type” when converting an Office
document to H/PC format?

Probably because the Office text con-
verters and graphics filters are not in-
stalled. Once you install them, the
problem should go away.

When a user customises printer set-
tings in Windows CE, the changes
don’t appear to be saved.

This is a known bug in Windows CE
2.0.

My users use the Cc and Bcc to send
copies of emails. However, when en-
tering the Cc or Bcc address, it often
gets copied to the To: line as well.

This can happen if the user adds an
address to the To line of an email mes-
sage before adding an address to the
Cc or Bcc lines of the message. Mi-
crosoft confirms it as a bug in CE. To
resolve the problem, add addresses to
the Cc or Bcc lines before filling in the
To: line. To do this:

1 Double-tap Inbox.

2 On the Compose menu, tap New
Message.

3 Tap CcorBcc,and thentap Address
Book on the Compose menu.

4 Tap the email address you want,
and then tap OK.

5 Repeat steps 3-4 until you add all
the email addresses you want.

6 Tap To, and then tap Address Book
on the Compose menu.

7 Tap the email address you want,
and then tap OK.

8 Repeat steps 6-7 until you add all
the email addresses you want.

Alternatively, you can manually en-
ter the addresses you want, as follows:

1 Double-tap Inbox.

2 On the Compose menu, tap New
Message.

3 Tap To, Cc, or Bcc, and then use the
on-screen keyboard or the hand-
writing recognition feature to enter
the email address you want in the
appropriate line.

4 Repeatstep 3 for each email address
you want to add.

When we use World Clock to change
the home city on a CE machine,
Pocket Calendar doesn’t update sin-
gle-occurrence appointments. Recur-
ring appointments are updated
correctly.

This can occur if Pocket Calendar is
running when you use World Clock to
change from a home city that is on
daylight saving time to a home city
that is not on daylight saving time, or
to change from a home city that is not
on daylight saving time to a home city
that is on daylight saving time. It's a
bug in Windows CE 2.0 and 2.1. To
work around it, quit Pocket Calendar
before using World Clock to change
the home city. Or, use World Clock to
change the home city, quit Pocket Cal-
endar, and then start Pocket Calendar.
Or, use World Clock to change the
home city, reset the H/PC or P/PC,
and then start Pocket Calendar.

PCSAI
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New Reviews from Tech Support Alert

Anti-Trojan Software Reviews

A detailed review of six of the best anti trojan software programs. Two products
were impressive with a clear gap between these and other contenders in their
ability to detect and remove dangerous modern trojans.

Inkjet Printer Cartridge Suppliers

Everyone gets inundated by hundreds of ads for inkjet printer cartridges, all
claiming to be the cheapest or best. But which vendor do you believe? Our
editors decided to put them to the test by anonymously buying printer cartridges
and testing them in our office inkjet printers. Many suppliers disappointed but we
came up with several web sites that offer good quality cheap inkjet cartridges
with impressive customer service.

Windows Backup Software

In this review we looked at 18 different backup software products for home or
SOHO use. In the end we could only recommend six though only two were good
enough to get our “Editor’s Choice” award

The 46 Best Freeware Programs

There are many free utilities that perform as well or better than expensive
commercial products. Our Editor lan Richards picks out his selection of the very
best freeware programs and he comes up with some real gems.

Tech Support Alert

http://www.techsupportalert.com
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